installing puppet

Download from
http://reductivelabs.com/trac/puppet/wiki/DownloadingPuppet
or
http://reductivelabs.com/downloads/puppet/

Or use RPMS

* puppet-server (requires: puppet, ruby-ldap)
* puppet (requires: augeas, facter, ruby)